Delays when sending emails from eTrans to Microsoft addresse

Incident Report for TMS

Resolved

Resolved - This incident has been resolved and mail queues have returned to normal
Posted Sep 07, 2026 - 07:33 UTC

Identified

Update - Microsoft has accepted responsibility for the current email delays. More details can be found on their status page and below:

Issue ID: EX1467029
Affected services: Exchange Online
Status: Service degradation
Issue type: Incident
Start time: Sep 4, 2026, 10:19 PM GMT+12

User impact
Users may experience a delay in sending and receiving email messages from external domains in Exchange Online.
Posted Sep 04, 2026 - 13:02 UTC

Investigating

We are seeing delays in sending emails from eTrans to Microsoft domains.
All indicators point to a larger, global issue with Microsoft itself.
We will continue providing updates as they are available.
Posted Sep 04, 2026 - 11:37 UTC
This incident affected: FleetGO TMS (eTransWeb, Integrations & Notifications, Reporting & Documents).